La función SI de Excel

La función SI de Excel es de las funciones más populares de esta herramienta y permite realizar comparaciones lógicas entre valores.

funcion si excel

Como la función SI realiza operaciones lógicas, solamente puede obtener dos resultados: verdadero (true) si se cumple la condición de la comparación o falso (false) si no lo hace.

La sintaxis de esta función es la siguiente:

=SI([condición];[valor verdadero]; [valor falso])

Es decir, si se cumple la condición especificada en [condición], entonces la función devolverá [valor verdadero], si no, devolverá [valor falso].

Ejemplos de la función SI

Veamos algunos ejemplos muy sencillos de esta función:

  • =SI(A1="Sí";1;2): si el valor de la celda A1 es “Sí”, entonces devuelve 1, si no, devuelve 2.
  • =SI(A1=1;"Sí";"No"): si el valor de la celda A1 es 1, entonces devuelve la palabra “Sí”, si no, devuelve la palabra “No”.

Estos ejemplos están bien para ver cómo funciona SI, pero han sido muy triviales. Así que veamos también un ejemplo con un poco más de gracia: una hoja Excel con los resultados mensuales de la explotación de un negocio en la que usamos la siguiente fórmula con la función SI:

=SI(D2>0;D2&"€ de beneficio"; D2&"€ de pérdidas")

La hoja es la siguiente:

ejemplo beneficios perdidas simple
Ejemplo simple de la función SI que genera diferentes textos en función del resultado de cada mes.

Si te fijas en la imagen, la columna D contiene el resultado de cada mes que puede ser positivo (beneficio) o negativo (pérdidas). Para que quede más claro, le hemos aplicado un formato de celda que muestra los números negativos en rojo.

La función SI de arriba toma esa celda como criterio para comprobar si el importe es mayor que cero o no. Si lo es, concatena mediante el símbolo “&” el valor de la celda de resultado (D2 a D4) con la cadena de texto “€ de beneficio”, en caso contrario, “€ de pérdidas”.

Usar la función SI con varias condiciones

En la práctica suele ocurrir muchas veces que lo que hay que evaluar no se puede expresar como una única condición, sino que son varias condiciones las que se deben cumplir a la vez.

En este caso, la manera de usar la función SI es combinándola con la función Y, o bien, la función O. Es decir, en este caso usamos a su vez estas funciones en las condiciones de la función SI o lo que es lo mismo: anidamos varias funciones tal como se explica en el siguiente apartado.

En el siguiente artículo puedes ver ejemplos de funciones SI con varias condiciones:

Funciones SI anidadas

Dentro de los parámetros de la función SI se puede anidar cualquier otra función, ya sea la propia función SI u otras.

De este modo, podemos hacer nuestro ejemplo anterior un poco más elegante:

=SI(D2>0;A2&" ha generado "&D2&"€ de beneficio";A2&" ha generado "&ABS(D2)&"€ de pérdidas")

Ahora la tabla de arriba quedaría así:

Ejemplo un poco más avanzado de la función SI que genera diferentes textos en función del resultado de cada mes.

Aparte de lo más evidente, la cadena de texto con el mes que ahora hace de prefijo, hemos usado la función ABS para introducir un cambio muy sutil: cuando se trata de pérdidas, la cifra ya no se muestra como negativa en el texto, lo cual en el contexto de la frase tiene más sentido.

Del mismo modo, podríamos, en vez de la función ABS, podríamos haber usado otra función SI. Esto sería el caso de varias funciones SI anidadas.

Como también tenemos un artículo específico para este caso, con varios ejemplos de funciones SI anidadas, te remito a su lectura:

Funciones relacionadas

También te puede interesar aprender más sobre estas funciones:

Acerca del autor: Berto López

Soy autor y fundador de este blog, e Ingeniero en Informática de formación con amplia experiencia: he trabajado como empleado, empresario, incluso funcionario. Vamos, que he probado de todo 😄

¿Te gustaría leer un poco más sobre éste u otros temas?