Cómo usar la función SI con varias condiciones en Excel

En ocasiones necesitarás usar la función SI de Excel con varias condiciones. Aunque solo admite un único parámetro de condición, afortunadamente hay una manera sencilla de hacerlo.

funcion si excel varias condiciones

El truco para poder usar varias condiciones consiste en aprovechar la función Y y la función O.

Gracias a que es posible anidar funciones, puedes usar estas funciones en los parámetros de la función SI, tanto en la condición como en los parámetros de los valores devueltos.

Recuerda que la sintaxis básica de la función SI es la siguiente:

=SI([condición];[valor verdadero]; [valor falso])

Si se cumple la condición especificada en [condición], entonces la función devolverá [valor verdadero], si no, devolverá [valor falso].

Para indicar varias condiciones, podemos usar para [condición] las dos funciones lógicas arriba mencionadas.

De hecho, las podemos usar incluso también en los dos parámetros de valores, pero aquí me voy a limitar a ejemplos que sustituyen el parámetro de condición, ya que la lógica es la misma.

Recuerda también la sintaxis y lógica de estas dos funciones:

=Y([condición 1];[condición 2])

Devolverá verdadero si se cumplen ambas condiciones, si no, falso.

=O([condición 1];[condición 2])

Devolverá verdadero si se cumple, al menos, una de las dos condiciones, si no, falso.

Por tanto, por ejemplo, si necesitamos que se cumplan dos condiciones en una función SI, el esquema general sería este:

=SI(Y([condición 1];[condición 2]);[valor verdadero]; [valor falso])

Podemos seguir anidando funciones Y para ir ampliando este esquema:

=SI(Y(Y([condición 1];[condición 2]);[condición 3]);[valor verdadero]; [valor falso])

Ahora ya se tienen que cumplir tres condiciones.

Del mismo modo, usando la función O, tendríamos:

=SI(O([condición 1];[condición 2]);[valor verdadero]; [valor falso])

Con esto, bastaría con cumplir, al menos, una de las dos condiciones para que la función SI devuelva un valor verdadero.

Y, por supuesto, podemos combinarlas:

=SI(Y(O([condición 1];[condición 2]);[condición 3]);[valor verdadero]; [valor falso])

Aquí, para que la función SI devuelva verdadero, se tienen que cumplir o la condición 1 o la 2 o ambas y, en todo caso, la condición 3.

Como te puedes imaginar, podemos hacer este esquema tan complejo como queramos.

Ejemplo de la función SI con varias condiciones

Como siempre, todo esto se ve mucho mejor con un ejemplo, así que aquí va uno:

ejemplo funcion si colores
Ejemplo de la función SI con varias condiciones.

En este ejemplo estamos clasificando colores según la sensación subjetiva que nos generan. Lo hemos hecho con las siguientes condiciones:

  • Consideramos los colores negro y azul, colores “serios”.
  • Y al resto de colores de la tabla colores “alegres”.

Esto lo podemos expresar con la siguiente fórmula en la fila 2:

=SI(O(A2="Negro";A2="Azul");A2&" es un color serio";A2&" es un color alegre")

Como siempre, aplicamos esta fórmula a las siguientes filas arrastrando simplemente la celda que la contiene (B2).

Acerca del autor: Berto López

Soy autor y fundador de este blog, e Ingeniero en Informática de formación con amplia experiencia: he trabajado como empleado, empresario, incluso funcionario. Vamos, que he probado de todo 😄

¿Te gustaría leer un poco más sobre éste u otros temas?