Cómo usar Horas y Tiempo negativo en Excel sin Errores

Cuando queremos calcular el tiempo transcurrido entre dos horas debemos restarlas entre sí, pero hay situaciones en las que la segunda hora es anterior a la primera, y al hacer la resta nos da error, mostrando “###” en la celda.

Hay varios métodos para solucionar esto y en este post vemos el más sencillo de todos.

Vamos allá 😊

¿Cómo usar Horas y Tiempo negativo en Excel?

Como te decía en la introducción vamos a ver como usar las horas en negativo de la forma más sencilla: con dos funciones:

  • Función Texto, que convierte un valor en texto, con un formato de número específico.
  • Función “ABS”, que devuelve el valor absoluto de un número, y por tanto, sin signo.

En la columna “A” tenemos la primera hora y en la columna “B” tenemos la segunda.

La columna “C” es donde iremos poniendo la diferencia de horas y, por tanto, donde vamos a hacer el cálculo.

horas diferencia excel
Este es el esquema que seguiremos.

Para un cálculo de horas normal, la fórmula que tendría que haber en la celda “C2” sería:

“=B2-A2”.

error restar horas excel
Al ser mayor la primera hora, el cálculo da error.

Como vimos antes, esto da error al ser la primera hora mayor que la segunda, y por tanto, en la celda “C2” vamos a escribir: “=TEXTO(ABS(B2-A2);"-h:mm:ss")”.

restar horas negativas excel
Puedes copiar la fórmula y modificarla con tus datos.

Con esto ya tendríamos nuestro resultado bien calculado.

restar horas negativas bien excel
Las horas se muestran en negativo.

¡Importante!, puedes copiar esta fórmula, pero no te olvides de quitarle las comillas que hemos puesto al principio y al final.

Acerca del autor: Lucía Berlanga

Soy colaboradora de esta web. Me he formado en el tratamiento de datos, desde su extracción, al análisis y visualización, y disfruto mucho con el desarrollo web.

Por otra parte, también estoy enfocada al diseño y desarrollo web, junto al marketing digital.

¿Te gustaría leer un poco más sobre éste u otros temas?